More on motherboards (even mATX!) for Xeon Phi

This is a short follow on to my previous post about motherboards for the Xeon Phi.

As we pointed out before, the Xeon Phi requires a motherboard and BIOS with large "Base Address Register" support. You need that enabled, and are likely to find this referred to in your BIOS as something similar to;

PCI 64bit Resource Handling Above 4G Decoding    [Enabled]

What if it still doesn't work!?

If you have the right BIOS settings, and they are enabled, and you are still not able to get the driver to see your Phi then look at the output of lspci for your card, (my card is tagged with 01:00 on the bus) for example;

[kinghorn@mini ~]# lspci -s 01:00 -v
01:00.0 Co-processor: Intel Corporation Device 225d (rev 20)
        Subsystem: Intel Corporation Device 3608
         Region 0: Memory at [ignored] (64-bit, prefetchable) [size=8G] 
         Region 4: Memory at f0000000 (64-bit, non-prefetchable) [size=128K] 

If you see something like the above with that glaring "unknown" then try this;

append pci=noapic to the kernel boot parameters

You can do this during boot before the kernel loads by hitting tab when grub starts up and then "a" to edit the append line. Later you can add this to the kernel stanza in grub.conf.

I was able to get a couple of micro ATX Haswell motherboards working with Xeon Phi using the pci=noapic kernel parameter with the result being the nifty little gem below, the Peak mini! (we needed a custom BIOS from ASUS for this one)

Tags: , ,